######################################################################## ### Using "make world" Under FreeBSD on x86 Systems ### Copyright (c) 2003-2005 Jerry Y. Wang ### $Id: make_world.txt,v 1.16 2005/11/21 08:21:21 jerry Exp $ ### ### NOTE: Use sudo or root for all steps below. ######################################################################## ############### ### FIRST TIME: ############### # STEP ONE: cp -i /usr/share/examples/etc/make.conf /etc/ vi /etc/make.conf # Uncomment and edit the CPUTYPE? line. # Uncomment the "NO_PROFILE=" line and set it to "true". # STEP TWO: cp -i /usr/share/examples/cvsup/stable-supfile /etc/ vi /etc/stable-supfile # Edit the "*default host" line. # Edit the "*default release=cvs tag=RELENG_6" line if necessary. # Comment out the "*default compress" line if you have a T1 or better. pkg_add -vr cvsup-without-gui cvsup -g -L 2 /etc/stable-supfile # STEP THREE: cd /sys/i386/conf # or /sys/amd64/conf, or whatever cp -i GENERIC MYKERNEL vi MYKERNEL # Edit for your hardware and needs. echo 'KERNCONF=MYKERNEL' >> /etc/make.conf ############### ### EVERY TIME: ############### # STEP ONE: cvsup -g -L 2 /etc/stable-supfile chflags -R noschg /usr/obj/* rm -rf /usr/obj/* /usr/src/usr.sbin/mergemaster/mergemaster.sh -p # STEP TWO: cd /usr/src make -j4 buildworld buildkernel installkernel # Recommended: reboot to single-user ("boot -s" from the loader prompt) # now before continuing. mergemaster -p make installworld # STEP THREE: mergemaster shutdown -r now ################################################################# ### All of the above was summarized from the FreeBSD Handbook at: ### http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/ #################################################################