### Installing and Configuring FreeBSD 7 # Always use defaults (just hit Enter) with the following exceptions: # # Pick the "Standard" install. # Use the entire disk ("a" and then "q"). # Use the "Auto Defaults" partition scheme ("a" and then "q"). # Pick the "X-User" distribution set ("Minimal" if it's a server). # Enter your network settings when prompted. # Say YES to enabling SSH if it's a server. # Pick "America -- North and South", then "United States", then "Pacific". # Say NO to Linux Binary Compatibility. # Say NO to the FreeBSD packages collection. # Add yourself as a user with 0 as a member group. # Say YES to visiting the general configuration menu. # Pick Networking. # Pick Ntpdate. # Pick Other and specify an NTP server or pick one from the list. # When you're done, exit the install and confirm when prompted. # Remember to remove the CD so that it doesn't boot from that. # After the reboot completes, log in as root. # Blank the network face. killall sendmail killall syslogd syslogd -ss vi /etc/rc.conf # Add these lines with no leading '#' characters. # sendmail_enable="NONE" # syslogd_flags="-ss" # Note that you should NOT add the extra 's' flag to syslogd if you need # to log to remote servers. # Use larger TCP send buffers and base MSS on a 1500-byte MTU. sysctl net.inet.tcp.sendspace=65535 sysctl net.inet.tcp.mssdflt=1460 vi /etc/sysctl.conf # Add these lines with no leading '#' characters. # net.inet.tcp.sendspace=65535 # net.inet.tcp.mssdflt=1460 # Set up ntpd *or* a job to run ntpdate daily. # To set up daily ntpdate via cron: crontab -e # Add this line with no leading '#' character (replace time.nist.gov). # 0 0 * * * /usr/sbin/ntpdate time.nist.gov >/dev/null 2>&1 || echo ntpdate failed # Set up software builds. cp -i /usr/share/examples/etc/make.conf /etc/ vi /etc/make.conf # Uncomment and edit the CPUTYPE? line. # Avoid annoying dialog screens during portinstalls. echo 'BATCH=true' >> /etc/make.conf # If it's a server, other good make.conf settings are: # NO_GUI=true # WITHOUT_X11=true # Install the Ports tree. portsnap fetch extract # Install portupgrade. pkg_add -vr portupgrade # Install sudo, grant privileges, and create user accounts. portinstall -P sudo /usr/local/sbin/visudo vipw # Done. Log out of the console.